roxen.lists.pike.general

Subject Author Date
Re: MutexKeys, garbage collectors, destructors and optimisers Martin Stjernholm <mast[at]lysator[dot]liu[dot]se> 04-02-2009
"Stephen R. van den Berg" <<srb[at]cuci.nl>> wrote:

> Ok, then we get back to syntax.
> It would be either:
> a. A block construct as you propose.
> b. A modifier to the declaration of the variable.
> c. A property of the destructor of the class.
>
> (c) is nicest, but changes it into a runtime check, which is bad for
> optimising.
> (b) is the most C like, but requires yet another reserved word.
> So most likely, (a) is the only option.

Actually, I just didn't think of a modifier. I think that's the way to
go. Some day we should take the plunge with a couple new modifiers
anyway, I believe. And it might be possible to kludge the compiler to
make them just "semi-keywords".